当前位置:首页 > 软件下载 > 编程开发 > 编程软件 > amis前端代码框架官方免费版 v1.1.1 最新版

amis前端代码框架官方免费版 v1.1.1 最新版

评分:5

amis官方版是一款用于前端web技术的代码编程工具,它为用户们直接提供了一个完整的框架结构,无需从最基础开始编程,可以帮助用户很快速的进行网站的建设,非常方便。amis框架还支持许多的实用辅助功能,包含了代码高亮,语句分层等等,让你轻松进行代码编程哦。

amis官方版该软件完全免费使用,也可以搭配其他相关编程工具同步使用,网页前端开发工作效率大幅度提高。

amis官方版软件特色

1、不需要懂前端:在百度内部,大部分amis用户之前从来没写过前端页面,也不会JavaScript,却能做出专业且复杂的后台界面,这是所有其他前端UI库都无法做到的;

2、不受前端技术更新的影响:百度内部最老的amis页面是4年多前创建的,至今还在使用,而当年的Angular/Vue/React版本现在都废弃了,当年流行的Gulp也被Webpack取代了,如果这些页面不是用amis,现在的维护成本会很高;

3、享受amis的不断升级:amis一直在提升细节交互体验,比如表格首行冻结、下拉框大数据下不卡顿等,之前的JSON配置完全不需要修改;

4、可以完全使用可视化页面编辑器来制作页面:一般前端可视化编辑器只能用来做静态原型,而amis可视化编辑器做出的页面是可以直接上线的。

5、提供完整的界面解决方案:其它UI框架必须使用JavaScript来组装业务逻辑,而amis只需JSON配置就能完成完整功能开发,包括数据获取、表单提交及验证等功能,做出来的页面不需要经过二次开发就能直接上线;

6、内置100+种UI组件:包括其它UI框架都不会提供的富文本编辑器、条件组合等,能满足各种页面组件展现的需求,而且对于特殊的展现形式还可以通过自定义组件来扩充;

7、容器支持无限级嵌套:可以通过组合来满足各种布局需求;

8、经历了长时间的实战考验:amis在百度内部得到了广泛使用,在4年多的时间里创建了3万+页面,从内容审核到机器管理,从数据分析到模型训练,amis满足了各种各样的页面需求,最复杂的页面有超过1万行JSON配置

amis前端代码框架官方免费版 v1.1.1 最新版

amis官方版更新内容

Feature

新增多页应用渲染器,自带左侧树形导航(#1351),文档

新增Grid2D布局容器,可实现复杂二维布局(#1334),文档

新增ChartRadios,可实现基于图表点击来切换数据(#1337)

支持在移动端或其它语言下使用不同配置(#1345),移动端文档、多语言文档

增加animation-duration设置,可以控制所有动画时长,也能用于关闭所有动画效果(#1303)

UUID支持设置长度来生成短随机数(#1325)

JSON无数据时显示placeholder(#1326)

Combo支持服务端校验、以及onValidate支持(#1331)

Enhancement

优化Form未保存离开页面功能(#1315)

优化jssdk文件下载判断(#1319)

优化JSON显示(#1348)

验证规则中的参数支持变量(#1356)

表单项name支持中括号(#1316)

Bugfix

修复在新版Firefox下jssdk报错(#1300)

修复css变量不支持数字问题(#1302)

修复echarts5jssdk报错问题(#1311)

修复actionType:reload时,配置close无效问题(#1331)

修复表单中有Button-Group时,不显示默认提交按钮(#1341)

修复Select检索时,敲空格,会导致整个下拉收起(#1344)

修复Nested-Select上下闪动问题(#1346)

修复RadiosvalueField失效问题(#1347)

修复InputGroup验证问题(#1357)

修复Picker请求选项接口多次的问题(#1358)

修复Combo>Table中text输入可能会被重置的问题(#1360)

修复tinymce的弹窗有可能被遮挡问题(#1336)

tinymce、axios版本升级,修复可能的安全漏洞

amis官方版相关问题

如何实现左侧导航栏页面跳转?

在1.1.1之后的版本提供了新的app组件,可以基于它实现导航功能,请参考https://github.com/fex-team/amis-admin项目。

另外amis团队还开发了「爱速搭」,即便完全不懂前端也能基于它开发应用。

集成到React项目中报错?

一般都是因为React、Mobx、mobx-react版本有关,参考amis项目的package.json,将版本保持一致,尤其是Mobx,目前amis中使用的版本是4,因为兼容性的考虑短期内不会升级到5/6,使用MobX5/6肯定会报错。

有的功能在官网示例中能用,但在React/SDK中无法使用?

如果提示找不到渲染器,那肯定是版本较老,尝试以下两种方法解决:

使用最新beta版本,方法是去npm查看最新版本号,比如最新版本是1.1.2-beta.2,就运行运行npmiamis@1.1.2-beta.2命令,在node_modules/amis/sdk目录中也能找到对应的sdk代码。

如果还是报错,可以使用最新代码自动编译的sdk

amis前端代码框架官方免费版 v1.1.1 最新版 软件截图
amis前端代码框架官方免费版 v1.1.1 最新版

amis前端代码框架官方免费版 v1.1.1 最新版下载地址

  • PC版

amis前端代码框架官方免费版 v1.1.1 最新版

相关版本

本类排行

  • 周排行/
  • 月排行